Advanced Microcontroller Audio Workshop

This workshop is intended to introduce you to the Teensy Audio Library and its audio system design
tool. If you're accustomed to 8 bit microcontrollers, you will be pleasantly surprised how much

capability a modern 32 bit processor provides.

For the latest copy of this document, parts list and more details, please visit:
https://www.pjrc.com/store/audio tutorial kit.html

Section 1: Install Software and Play Music

In this first section, you set up software on your computer, make Teensy play music, and make Teensy

perform other tasks while the music is playing.

Part 1-1: Install Arduino & Teensyduino 1.58

Your workshop kit includes a SD card reader and a Micro SD card with all the required files.

Step #1: Plug the card into your laptop and copy all of its files to a
folder on your hard drive.

Step #2: Install Arduino & Teensyduino. This workshop
requires Teensyduino 1.58 or later, using Arduino 1.8.19
or Arduino 2.0.4 or later.

Detailed installation instructions and downloads can be found at this page:
https://www.pjrc.com/teensy/td download.html

Arduino 2.0.4 needs internet access to install Teensy support

- -

files. File Edit Sketch Tools Help
1: Install and run Arduino 2.0.4 (or later) BOARDS HANAGER
2: Click File > Preferences toensy
3: Add https://www.pjrc.com/teensy/package teensy index.json | B2 e A v
to Additional boards manager URLs Teensy by Paul Stoffegen

. Boards included in this package:
4: Click Tools > Board > Boards Manager Teensy 4.1, Teensy MicroMod

Teensy 4.0, Teensy 3.6, Teensy
. ¢ » 35, Teensy 3.2, Teel

5: Search for “teensy e
6: Click INSTALL el

157.2v INSTA

Arduino 1.8.19 is best without internet access.
Windows / Linux

1: Run Arduino 1.8.19 installer or extract Arduino 1.8.19 (and remember location)
2: Run Teensyduino installer

Macintosh:

1: Extract Teensyduino zip file.
2: On first run, allow access to Documents folder
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sketch_feb8a.ino

—

© W00~ O U W N |

void setup() {

-

void loop() {

—


https://www.pjrc.com/teensy/package_teensy_index.json

Step #3: Configure Arduino for Teensy 4.0. In Arduino select Tools > Boards > Teensy 4.0

sketch_mar28b | Arduino IDE 2.0.4

Auto Format
Archive Sketch

sketch_mar2|

Manage Libraries... Ctrl+Shift+

| Serial Monitor Ctrl+Shift+M

Serial Plotter

—

WIFi101/ WiFININA Firmware Updater
Upload SSL Root Certificates

=

Board: "Teensy 4.0" » Boards Manager...  Ctrl+Shift+B
Port: "usb1/1-1/1-1.3" L
Get Board Info

Arduino AVR Boards E

DNV A WNE
—

Teensy 4 Teensy 4.1

-

Keyboard Layout: "US English"”
Optimize: "Faster”

CPU Speed: "600 MHz"

USB Type: "Serial"

Teensy MicroMod

¥ Teensy4.0 )

Teensy 3.6

Teensy 3.5
Teensy3.2/3.1

Taancu1n

Burn Bootloader

Step #4: Verify an example to make sure Arduino can compile the workshop files.

Open the example file, from File > Examples > Audio > Tutorial > Part_1_02_Hardware_Test

Adarruit 5TMPEST0 4
Adafruit_nRF8001 bR
File Edit Sketch Tools Help Adafruit_V51053 4
New Sketch Ctrl+N ADC ’
ou AltSoftserial 4
Open... ctrl+0 Artnet L
Open Recent v Audio b Analysis
sketchbook »  Bounce * Dynamic ¢
Examples »  Bounce2 »  Effects L
Close CapacitiveSensor * HardwareTesting 4
Save DmxSimple * MemoryAndCpuUsage
Save As... Chrl+ShiFt+S DogLcd F Queues r
- DS1307RTC ¥ Recorder
Rieieences - SHcomme EasyTransfer »  SamplePlayer
Advanced »  EasyTransferi2C » Synthesis »
_— o EEPROM »  Tutorial ¥ Part_1_.02 Hardware_Test
Encoder *  WavFilePlayer Part_1_03 Playing_Music
Entropy * WavFilePlayerPause Part_1_04_Blink_While_Playing
FastCRC 4 Part_1_05_Do_More_While_Playing
FastLED K Part 2 01 First Desian Tool Use

Click the Verify button. If Arduino and Teensyduino and libraries are installed properly, after several
seconds the you should see this message.

Output  Serial Monitor =

@ Done compiling. b4

2 indexing: 0/1 Ln51,Col28 Teensy4.0 onusb1/1-1/1-1.3 (22 B

This workshop uses the examples from File > Examples > Audio > Tutorial
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Part 1-2: Test Hardware

Your workshop package contains a breadboard with the Teensy, Audio Shield, and push buttons and
pots already assembled.

Step #1: Gently plug in the USB cable and headphones
Step #2: Plug the USB cable into your computer, and click Upload in Arduino.

You should hear a regular beep on your headphones, once every 2 seconds.
If Windows shows detecting new hardware, DO NOT cancel. Allow it to complete!

Step #3: Use Arduino's Tools > Ports to select the Teensy serial port. If you are unsure which is
Teensy, you may unplug the USB cable (but not while Windows is detecting new hardware!)
and try the Tools > Ports menu again to see which port vanished.

Step #4: With the proper port selected, open the Arduino Serial Monitor, using the Tools > Serial
Monitor menu.

Output  Serial Monitor X ¥ G) =
BothNLECR +

Beep #198

Button (pin @) Press
Button (pin @) Release
Button (pin 8) Press
Button (pin 8) Release
Button (pin 1) Press
Beep #199

Button (pin 1) Release
Button (pin 2) Press
Beep #200

Button (pin 2) Release

Knob (pin A2) = 204
Knob (pin A2) = 153
Knob (pin A2) = 182

Beep #201

Ln51,Col28 Teensy4.0onush1/1-1/1-1.3 (22 O

You should see a Beep message for each headphone beep. Pressing the buttons and turn the 2 pots on
the breadboard. All should respond. You will need these, so it's important to verify they work before
proceeding.
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Part 1-3: First Program, Play Music

With everything installed, you're ready to replace that beeping with music.
Step #1: Open the example sketch for Part 1-3.

File > Examples > Audio > Tutorial > Part_1_03_Playin

sketchbook q
Examples V AltsoftSerial »
ciaas Artnet »
Save Audio » Analysis
Save As... Bounce L Dynamic
Bounce2 r Effects
Preferences... Cuoihinne CapacitiveSensor » HardwareTesting
Advanced > DmxSimple 2 MemoryAndCpuUsage
DogLcd > Queues >
Quik Crl+Q
i = & d DS1307RTC 2 Recorder
EasyTransfer » samplePlayer
Beep #434 R
Beep #435 EasyTransferi2C . Synthesis 4
Beep #436 EEPROM » Tukorial o Part_1_02_Hardware_Test
Beep #437 Encoder » wavFilePlayer Part_1_03_Playing_Music
Beep #438 e = =
Beep #439 Enktropy » WavFilePlayerPause Part_1_04_Blink_While_Playing
Beep #4460 FastCRC » Part_1_05_Do_More_While_Playing
Beep #441 . .
Beep #442 FastLED 3 Part_2_01_First_Design_Tool Use

Step #2: You should click Verify now, but do not Upload yet. Arduino can take quite a while to
compile the entire audio library, so start the verify step now.

Step #3: Insert the Micro SD card from the card reader and into the Teensy Audio Shield before you
Upload the program. The music files are stored on this MicroSD card.

File Edit Sketch Tools Help

——

Part_1_03_Playing_Music.ino

@OO\JU!LH-EAUJN}—‘|
=

10
11 #include <Audio.h>

12 #include <Wire.h>
12 Hincluda ~CDT hw

You should now be hearing music rather than simple beeping.
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Part 1-4: Blink LED while Playing Music

Real projects need to do more than just play music. Great sound isn't so great if it imposes difficult
requirements on the rest of your program. Let's try doing some simple things with the audio plays.

Step #1: Open the Part 1-4 example
File > Examples > Audio > Tutorial > Part_1_04_Blink_While_Playing

Part_1 04_Blink_While_Playing.ino

61 wvoid loop() {

62 if (playSdwavl.isPlaying() == false) {
63 Serial.println("Start playing");

64 playSdWavl.play("SDTEST3.WAV");

65 delay(10);

66 }

67

68

69 Serial.print("Playing, now at "};

70 Serial.print(playSdWavl.positionMillis());
71 Serial.println(" ms"};

72

73 in

74 digitalWrite(LED_PIN, HIGH);

75 delay(250);

76 digitalWrite(LED_PIN, LOW);

77 delay(250);

78

79

an

Step #2: Verify and Upload this sketch.

When you run this example, you'll see the messages about playing appear in the Arduino Serial
Monitor. If you look between the Audio Shield and Teensy, you can see the LED blinking.

The key point is your Arduino code can use delay(), Serial.print() and other common Arduino features.
The audio keeps playing during those delays.

Step #3 (optional): Uncomment the volume knob code near the end of this sketch and Uplead. When
you turn the knob, there's a lag before the volume changes. In Part 1-5 we will look at a way to
prevent this problem.

Step #4 (optional): What happens if you reduce the delays? Or if you completely remove them? Or
print even more text? Can you get extremely fast transmission to the Arduino Serial Monitor to make
the audio stutter?

Section 1 - Achievement Unlocked

Congratulations! You've completed the essential material of Part 1. If you have time, keep exploring
more of Section 1, or skip ahead to start Section 2.
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Part 1-5 : Do More While Playing Music

In the previous part, we saw you can use delay() without disrupting the audio library, but it does
prevent your program from rapidly responding to user actions. In this part, we'll blink the LED
without using delay, so our sketch remains responsive. We'll also look in more detail at reading the
knobs and buttons to do more things while the music plays, and mention some of the finer details of
the Arduino sketch example code.

Step #1: Open the Part 1-5 example
File > Examples > Audio > Tutorial > Part_1_05_Do_More_While_Playing

Part_1_05_Do_More_While_Playing.ino &

LDOU“-IO'\UTJ‘-‘-UJNP—'|

10

11

12 #include <Audio.h>

13  #include <Wire.h>

14 #include <SPI.h>

15 #include <SD.h>

16 #include <SerialFlash.h>
17 #include <Bounce.h>

18

19 AudioPlaySdwWav playSdWavl;

20 AudioOutputI2s i2sl;

21 AudioConnection patchCordl(playSdwWavl, @, i2sl, @);

Step #2: Verify and Upload this sketch.

As this sketch runs, you should see the LED blink. The knob controls the volume immediately,
regardless of where the LED is within its blinking cycle. The left and right pushbuttons allow you to
cycle through the 4 songs.

The blinking without delay uses a special elapsedMillis variable, which acts like a normal 32 bit
integer, but it automatically increments 1000 times per second.

71 elapsedMillis blinkTime;

72

73  void loop() {

74

75 if (playSdWavl.isPlaying() == false) {

This makes blinking without delay very simple. If the “blinkTime” variable is still under 250, the LED
should be off. If it's incremented to between 250 to 500, the LED needs to be on. If it's gone past 500,
simply set it back to zero to restart the blink cycle.

85 :

86 if (blinkTime =< 250) {

87 digitalWrite(LED PIN, LOW);

88 } else if (blinkTime =< 500) {

89 digitalWrite(LED PIN, HIGH);
90 } else {

91 blinkTime = 0;

92 }
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The pushbuttons are read using the Bounce library. While you could use Arduino's digitalRead()
function to directly read the pins, Bounce automatically handles mechanical chatter in the button, and
it does this without requiring a delay which could slow our response to other user input.

The Bounce library is easy to use, but it does require a few small pieces of code. First, a Bounce
object is created for each button. The digital pin number and worst-case mechanical chatter time are
given.
25 Bounce button®
26 Bounce button2

Bounce(®, 15);
Bounce(2, 15);

Inside setup(), the digital pins need to be configured with INPUT_PULLUP mode. The buttons
connect the pin to ground, so the pullup causes the pin to be high when the button isn't pressed.

58 }

59 pinMode (LED PIN, OUTPUT);
60 pinMode (0, INPUT PULLUP);
61 pinMode (2, INPUT PULLUP);
62 delay(1000);

63 1}

Inside loop(), the buttons are checked using update() and fallingEdge(). Because the button connects
to ground, the moment the button is pressed is called the falling edge. The Bounce library allows us to
reliably detect the falling and rising edge, even if the button has chatter, and without ever delaying our
sketch.

94

a5 button®.update()

96 if (button@.fallingEdge()} {
97 playSdWavl.stop();

98 1

99 button2.update()

100 if (button2.fallingEdge()) {
101 playSdWavl.stop();

102 filenumber = filenumber - 2;
103 if (filenumber < 0) filenumber = filenumber + 4;
104 1

All the examples in this tutorial use Bounce to read the pushbuttons.

This final piece of code, which we'll see repeated throughout this workshop, reads one of the knobs.
The Arduino analogRead() function gives an integer between 0 to 1023.

106

107 int knob = analogRead(A2);

108 float vol = (fleoat)knob / 1280.0;
109 sgtl5000 1.volume(vol);

110

111

112 }

Most audio library functions need a floating point number between 0 to 1.0, so throughout this
workshop you will see equations which convert the 0-1023 integer. In this case, volume more than 0.8
is much too loud. Each example varies slightly, but these basic concepts are used throughout the
example code in this workshop.
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Section 2: Creating Audio Systems

The previous examples had collections of objects to play music. In this section, we'll explore how to

use the design tool to create our own audio systems.

Part 2-1: First Design Tool Use

Step #1 (with Internet connection):

To run the design tool, open a web browser and go to http://www.pjrc.com/teensy/gui

When the design tool first appears, you'll see a blank canvas in the center panel. The left side is a list
of all the audio objects grouped into functional categories, and the right side shows documentation.

.input |
i2s
i2s_guad
i2s_hex
i2s_oct
i2sslave
252
spdif3
spdif_async [
adc
adcs
pdm
pdm2
tdm
tdm2
usb
uoutpt.jt |
i2s
i2s_guad
i2s_hex

i2s_oct

Special thanks to Nicholas O'Leary, Dave

info

Welcome

The Audio System Design Tool lets you
easily draw a system to process 16 bit,
44 1 kHz streaming audio while your
Arduino sketch also runs.

Export will generate code to copy into the
Arduino editor, to implement your system.

Most objects provide simple functions you
can call from setup() or loop() to control
your audio project!

Offline Use

This tool does not use a server. A stand-
alone copy is provided with the Teensy
Audio Library, in the gui folder.

Credits

Conway-Jones and IBM.

Without their work on the open source
Node-RED project, this graphical design
tool would not have been possible!
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http://www.pjrc.com/teensy/gui

Step #1 (without Internet access, using Windows or Linux, with Arduino 1.8.19):
The design tools files are located deep within Arduino. On Windows and Linux, Arduino is a
hierarchy of many folders and files. First, find your Arduino folder.

On Windows, the default Arduino location is C:\Program Files (x86)\Arduino.

From the main Arduino folder, navigate to these folders:

hardware / teensy / avr / libraries / Audio / gui
Inside the gui folder, open index.html.

Home Share View 0

« v <« Program Files (x86) > Arduino » hardware > teensy » awr > libraries > Audio > gui R J] Search gui »

3 Quick access

m Desktop P

& Downloads + B B ﬂ' » ]
% Documents +

= Pictures +* bootstrap font-awesome icons img Jquery orion

. winl0 ()

|
#& OneDrive 5 [ e
: L ] |

= This PC

m Desktop red favicon index style

Y VO

Step #1 (without Internet access, using Macintosh, with Arduino 1.8.19):
The design tools files are located deep within Arduino. On Macintosh, Arduino is a special application
bundle. Hold the Control key and click Arduino, and choose Show Package Contents.

Name Date Modified
8 siri Jan 13, 2023 at 4:57 PM
Applications @ stats Jan 25, 2023 at 12:66 AM
_ Stickies Jan 13, 2023 at 4:57 PM
@ Stocks Jan 13, 2023 at 4:57 PM
@& System Settings Jan 13, 2023 at 4:57 PM

& Teensy ™M
pen

/ TextEd ™
® Time M pove to Trash M
@ b
> [ Utilities  Get Info M
@B vVoice b Rename ™M
E) weathe Compress "Teensyduino” M
| Duplicate }
Make Alias

From the new windows which opens, navigate to these folders:

Contents / Java / hardware / teensy / avr / libraries / Audio / gui
Then open index.html

[ NON ] Teensyduino

Favorites ~ | Date Modified

2} paul RN CTF =T JUI ZU, ZULZ Al O\
filter_variable.cpp Jul 26, 2022 at 8:1

n | filter_variable.h Jul 26, 2022 at 8:(

[% Documents &3 gui Jul 26, 2022 at 81

> [ bootstrap Jul 26, 2022 at 8:1
=4 favicon.ico Jul 26, 2022 at 8:t

& Applications

@) Downloads

icloud > [0 font-awesome Jul 26, 2022 at 8:1
formulas.tex Jul 26, 2022 at 811

Jul 26, 2022 at 8:(
(2% Shared i Jul 26, 2022 at 8l

> [ jauery Jul 26, 2022 at 8:

< iCloud Drive

Locations

3 studio > [ orion Jul 26, 2022 at 8:

@ Network > @ red Jul 26, 2022 at 8:
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Step #2: Create an audio system

Scroll down the left panel. Objects are grouped by types. In the “play” section is playSdWav. Drag
this object onto the upper left corner of the canvas.

Then locate the i2s object in the “output” section. This i2s object sends digital audio data from
Teensy to the Audio Shield (I2S is a technical term for the signals which communicate digital stereo
sound). Drag i2s onto the canvas, to the right of the playSdWav object.

Special Note: do not use the i2ss object. Make sure you use i2s object.

pwm input v

255 5

mixer v playSdWav1

mixer i2ss

play v output v ) ) ) )
Transmit 16 bit stereo audio to the audio

playMem i2s shield or another 125 device, using 125
| ‘ master mode.
play%w.w y | Play a WAV file, stored on a SD card spdif |

playSdRaw dac

playFlashRaw

With both objects on the canvas, click (and hold) on their small squares, and drag your mouse to draw
wires. Each wire causes a stream of 16 bit, 44.1 kHz audio data to automatically flow between the
objects.

= : playSdWav1

B 4 =

One more object is needed to control the audio shield. Scroll down to the end of the object list, then
drag the sgtl5000 object onto the canvas. This is a special hardware control object, which does not
have audio connections, but must be present to control the Audio Shield hardware.

tone

print

Eontro) b ‘ Control the SGTLS000 chip on the audio ' P
shield. SGTLS000 is always used in slave £ Pl e \ y
sgtisnoo | mode, where Teensy controls all 125 x

timing.

i2s1

wma731 ‘
I

sgti5000_1

=

wma731im
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Step #3: When you've created an audio system, click the red Export button. The design tool will
create code which you copy (Ctrl-C) from its export window and paste into Arduino.

[ satlsnnn 1| H |Summ

‘ Export to Arduino

& source Code:

E

#include =SPI.h
#include <SerialFlash.h

nudioPlaySdwav playSdwavl; S/ ¥y=113,70
AudioQutputI2s iZs1; S /xy=311,9
sudioConnection patchCordl{playSdwavl, ©, i2s1, 0);
nudioConnection patchCord2{playSdwavl, 1, i2s1, 1);
AudioControlSGTL5000 sgtlseee 1; S iwy=232,15
// GUItool: end automatically generated code L
2 lio
Select the text above and copy to the clipboard with Ctrl-A Ctrl-C. ] bjec
ts. S
d an
r ma
Ok Cancel ise tl
500(
| | |dependsc

Step #4: In Arduino, open the Part 2-1 example
File > Examples > Audio > Tutorial > Part_2_01_First_Design_Tool_Use
and paste the code from the design tool into the commented section copy the Design Tool code here

Part_2 01 First Design_Tool Use.ino @

// Advanced Microcontroller-based Audio Workshop
I
// http:// pjrc.com/store/audio tutorial kit.html
// https://hackaday.io/project/8292-microcontroller-audio-workshop-had-supef§
7

// Part 2-1: First Design Tool Use

LILLTFIELEL TP PTEIfiiiir Y
// copy the Design Tool code here
YO JIIIIAIAIIN i iy
11 #include <Audio.h>

12 #include <Wire.h>

13 #include <SPI.h>

14 #include <SD.h>

15 #include <SerialFlash.h>

LNV s WN =

16

17 // GUItool: begin automatically generated code

18 AudioPlaySdWav playSdwWavl; //xy=88,55

19 AudioOutputI2sS 1251; //xXy=280,79

20 AudioConnection patchCordl(playSdwWavl, @, i2sl, 0);
21 AudioConnection patchCord2(playSdwWavl, 1, i2s1, 1);
22 AudioControlSGTL5@00 sgtl5000_1; //xy=209, 140

23 // GUItool: end automatically generated code

24

25

26 // Use these with the Teensy Audio Shield
27 #define SDCARD CS PIN 10
28 #define SDCARD MOSI PIN 7

Ln23,Col45 Teensy 4.0 onush1/1-1/1-1.3 0

Step #5: Verify and Upload after you've copied the design tool's exported code. This program is the
same basic song player from Part 1, but this time you've created the audio objects!
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Part 2-2: Mixers & Playing Multiple Sounds

Playing one stereo WAV file can be very useful in many projects, but
we can do so much more! Let's use mixers to combine sounds.

Step #1: Create an audio system in the design tool

First, find the mixer object.

1285
mixer v
Combine up to 4 audio signals together,
mixer ; each with adjustable gain. All channels
) | support signal attenuation or amplification.
play vl
playMem
playSdWav
playSdRaw

When you click any object, the right side updates with
documentation.

Most objects have functions which you can call from your Arduino
sketch, to configure or change what the object does. For the mixer,
each input channel has adjustable gain. These can be set once, or
changed at any time. In just a moment, you'll use the gain() function
to switch or fade between 2 songs. The design tool serves as a handy
reference manual when you write your code in Arduino.

To complete this example, draw a second playSdWav object onto the
canvas and connect the wires as shown. Each playSdWav has 2
outputs, for left and right channels. mixerl combines both left
channels and connects the left channel input of i2s1, and mixer2
combines both right channels and feed the right channel of i2s1.

£

. - _/_ _ mixerl ()
P ol
| playSdWav2 S mixer2

o ol .

e

i2s1

5=l Y
sqti5000 1 |
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Summary

Combine up to 4 audio signals together,
each with adjustable gain. All channels
support signal attenuation or
amplification.

Audio Connections

Port Purpose
In0  Inputsignal #1
In1  Inputsignal #2
In2 Inputsignal #3
In3 Inputsignal #4
Qut0 Sum of all inputs

Functions

gain(channel, level);

Adjust the amplification or attenuation.
“channel” must be 0 to 3. "level” may be any
floating point number from 0 to 32767.1.0
passes the signal through directly. Level of O
shuts the channel off completely. Between 0 to
1.0 attenuates the signal, and above 1.0
amplifies it. All 4 channels have separate
settings.

Examples

File = Examples = Audio > SamplePlayer

File > Examples > Audio > Synthesis >
PlaySynthMusic

File = Examples = Audio > Analysis >
SpectrumAnalyzerBasic

File > Examples > Audio > Analysis >
DialTone_Serial

File > Examples > Audio >
Memory AndCpulsage

Notes

Signal clipping can occur when any
channel has gain greater than 1.0, or
when multiple signals add together to
greater than 1.0.

More than 4 channels may be combined
by connecting multiple mixers in
tandem. For example, a 16 channel
mixer may be built using 5 mixers,
where the fifth mixer combines the
outputs of the first 4.




Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch

Step #3: In Arduino, open the Part 2-2 example
File > Examples > Audio > Tutorial > Part_2_02_Mixers and paste the code from the design
tool into the commented section copy the Design Tool code here

Step #4: To hear 2 songs playing together, Verify and Upload to Teensy. You should hear a jumble of
music, playing 2 songs of very different genres.

The design tool allows you to easily compose complex audio systems. Every object you place onto the
canvas continuously processes CD quality sound. Each wire causes a stream of digital (44.1 kHz, 16
bit) audio to automatically flow between 2 objects.

This code near the end of setup() is responsible for the not-so-pleasing mashup of these dissimilar
songs. This is the gain() function we saw documented in the design tool. Each channel is set to 0.5. If
both signals happen to be at maximum of +1.0 or -1.0 signal, the worst case is adding together to 1.0

Part 2 02_Mixers.ino @

gt T

56 Serial.println("Unable to access the SD card");
57 delay(500);

58 }

59 }

60 mixerl.gain(0, 0.5);
61 mixerl.gain(l, 0.5);
62 mixer2.gain(@, 0.5);
63 mixer2.gain(1l, 0.5);
64 delay(16680);

65 }

66

67 void loop() {

68 if (playSdwWavl.isPlaying() == false) {

69 Serial.println("Start playing 1"); L
70 playSdWavl.play("SDTEST1.WAV");

Signals are always be between -1.0 to 1.0. If you mix signals to a sum beyond 1.0, the result is limited
or “clipped” to 1.0. Clipping causes harmonic distortion. Gains are usually set to prevent clipping. If
you have extra time, try adjusting the gains to experience clipping distortion. Much of the practical
experience of audio design is familiarity with the sounds caused by common mistakes.

Near the end of this code is a section to uncomment. It will allow the A3 Knob to adjust the mixer
gains at both songs play. Many objects can be put to creative uses by calling their functions from
Arduino code while they're processing live audio.

Part_ 2 02 Mixers.ino e

1 ucLay |\ 1uy,

72 }

e if (playSdwWav2.isPlaying() == false) {
74 Serial.println("Start playing 2");
75 playSdWav2.play("SDTEST4.WAV");

76 delay(10);

77 }

78 uncomment this code

79

80 int knob = analogRead(A3);

81 float gainl = (float)knob / 1023.0;
82 float gain2 = 1.0 - gainl;

83 mixerl.gain(@, gainl);

84 mixerl.gain{1l, gain2);

85 mixer2.gain(@, gainl);

86 mixer2.gain(1l, gain2);

87

88 }

89
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Part 2-3: Playing Samples (Short Sound Clips)

For very short sounds, you can place the sound data directly into your program. Playing sounds from
Teensy's memory has 2 huge advantages:

1. It's much more efficient, allowing dozens of sounds to play simultaneously without reaching
microcontroller resource limits.

2. The SD card isn't needed. If you use the DAC output instead of 12S, a very small project can
be made without the large audio shield.

Step #1: Design and audio system

Draw this simple 4 sound player, using playMem objects. This system uses a connection type we
haven't seen before, where 1 object connects to 2 others. This is perfectly fine when 1 output transmits
to 2 or more inputs. However, you can't connect 2 signals to the same input. To feed more than 1

signal to any input, you must use mixers to combine them, which exactly what this system does for the
4 playMem objects.

playMem1

playMem?2 '-—......\____ 5 [ | i2st
__,'"- d

mixer1

playMem3 —/— ' “It]l':'

- sgtl5000_1
playMem4 () |
Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch
Step #3: In Arduino, open the Part 2-3 example
File > Examples > Audio > Tutorial > Part_2_03_Samples and paste the code from the
design tool into the commented section copy the Design Tool code here
Step #4: Verify the sketch and Upload it to Teensy.
Special Tip:
If you have been using copy & paste to an old window for faster Verify & Upload (as mentioned in Part 1-4),

that trick will not work with this example. This sketch has several extra files, which you can't easily copy
and paste.

Tapping the 3 buttons will play drum and cymbal sounds.
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Step #5 (optional): Enable Extra Sounds

Near the end of loop() you can find more complex code which allows the 3 buttons to play 6 sounds,
depending on the position of the A3 knob.

The gong and cash register sounds play for longer times. If you look at the code, the center button
uses playMem?2 in one case and playMem4 in the other. If you tap and turn quickly, can you get all 4
playMem objects making sound at the same moment?

Step #6 (optional): Experiment with mixer gain
While frantically tapping buttons, you might consider the mixer gain settings in this example. If all 4

sounds simultaneously produce a full 1.0 amplitude signal, we could end up with a sum to 1.6, which
could cause clipping and massive harmonic distortion.

o4 AudlOoMEemOry (1v) ;
55 sgtl5000 l.enable();

56 sgtl50600 1.volume(0.5);
57 mixerl.gain(@, ©0.4);

58 mixerl.gain(l, ©.4);

59 mixerl.gain(2, ©.4);

60 mixerl.gain(3, ©.4);

61 }

Can you notice any distortion by listening as you press all 3 buttons together? How about while the
gong still rings? (odds are any distortion will be extremely difficult to hear in this scenario)

If you have a strong background in software or engineering, you may be accustomed to rules based on
solid mathematical principles. Try adjusting and experimenting with the gain settings, perhaps set the
gains to 0.9 and Upload. Even with all 4 sounds able to add to 3.6, the louder output may still sound
better or more dramatic, even with some distortion possibly occurring.

Audio design tends to be very subjective. Experimenting and listening is the best way to learn.

In this workshop example, six sound samples were provided as additional files. As you can see in the
comments, these extra files are created by a program called “wav2sketch”. This is a command line
utility, which must be run from a Terminal (Mac, Linux) or Command Prompt (Windows).

Using wav2sketch isn't part of this workshop, but when you need to create your own samples, the code
can be found in the “extras” folder within the audio library. It's also available on Github, using this

link: https://github.com/PaulStoffregen/Audio/tree/master/extras/wav2sketch

Page 15 of 31


https://github.com/PaulStoffregen/Audio/tree/master/extras/wav2sketch

Part 2-4: Using the Microphone

Now it's time to try using the microphone. These are inexpensive mics, so you can expect telephone
quality sound.

For a first microphone test, use this simple system. The i2s input object provides stereo data, but when
the mic is in use both channels are the same data. Of course you want to connect to both outputs,
because listening with only 1 ear is unpleasant.

Step #1: Design an audio system

volume(level);

Setthe headphone volume level. Range is 0 o
1.0, but 0.8 corresponds to the maximum

. _ undistorted output for a full scale signal. Usually
les : 0.5 is a comfortable listening level. The line
D Q| izst 9

) level outputs are mofchanged by this function.
4 inputSelect(input);
Select which input to use:
5gt|5000—1 AUDIC_INPUT_LINEIN or AUDIC_INPUT_MIC.
micGain(dB);
When using the microphone input, set the

amplifier gain. The input number is in decibels,
from O to 63.

Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch
Step #3: In Arduino, open the Part 2-4 example
File > Examples > Audio > Tutorial > Part_2_04_Microphone_Check and paste the code

from the design tool into the commented section copy the Design Tool code here

Step #4: Verify the sketch and Upload it to Teensy.

Until now, every example has simply enabled the S ||| e s m————
31 sgt1l5000 1.volume(0.5);
SGTL5000 and set the headphone volume. If you 2 sgt15000 1.inputSelect(AUDIO INPUT MIC);
review the SGTL5000 documentation, it has a ;3 ;Z{;i?‘igaéﬂi““i"”ﬁ“
dizzying number of configurable features. By 5} '
default, the I2S input will use the line level input 0 L s

pins on the top edge of the audio shield. The
inputSelect() function is needed to use the mic.

Step #5: Experiment to find comfortable micGain setting.

The main setting to adjust is the micGain(). You can adjust between 0 to 63. Zero will not let you hear
anything with this mic, and 63 will amplify a lot of static and probably be far too sensitive.

In the following examples using the mic, edit the micGain() to whatever setting is comfortable.
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Part 2-5: Simple Delay
You can easily apply real-time effects using the design tool. In this part, we'll try the delay object.

Step #1: Design an audio system
When drawing this system, be careful to put mixer3 in the correct location. The example code

configures its gain settings differently than mixer1 and mixer2. Also, be careful to use delay, not
delayExt. The audio shields in this workshop are not equipped with RAM chip needed by delayExt.

i0sD -I" mixer3
mixeri Z D51

delayl

mixerz2
o) sgti5000 1

] 2

Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch
Step #3: In Arduino, open the Part 2-5 example
File > Examples > Audio > Tutorial > Part_2_05_Simple_Delay and paste the code from the
design tool into the commented section copy the Design Tool code here
Step #4: Verify the sketch and Upload it to Teensy.

When you load this into Teensy you should hear your voice very noticeably delayed.

Until now, we've ignored the AudioMemory() line in .
43 void setup() {

the setup() function of every example. a4 Serial.begin(9600):

AudioMemory() allocates the all memory the Teensy 45 | AudioMemory(160);

Audio Lib Th b . t 46 sgtl5008 1.enable();
udio Library uses. 1he number you give to 47 | sgt15000_1.volume(0.6);

AudioMemory() is the total number of 128 sample 48 | sgtl5000_1.inputSelect (AUDIO_INPUT MIC);
buffers. Normally very little memory is required, so % | R e

10 to 20 buffers are usually plenty. Each buffer

consumes 260 bytes of Teensy's RAM. You can see the impact of allocating more memory in
Arduino's console window. On Teensy 4.x, the increase applies to RAM?2 usage.

Qutput = 4O

Ln 45, Col 18 Teensy 4.0 on usb1/1-1/1-13 (%1

Step #5 (optional): Experiment with delay tap settings
In setup() are 8 lines which set all 8 delay outputs to 400 ms. Edit these to hear multiple delays!

Section 2 - Achievement Unlocked

Congratulations! You've completed all of the essential material of Part 2. If you have time, keep
exploring the more of Part 2, or skip ahead to start Part 3.
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Part 2-6: Feedback (Echo) Delay

Most audio systems connect all their wires in forward (left to right) direction. However, backward
feedback (right to left) wires are possible, especially to turn a delay into a repeating echo.

Step #1: Design an audio system

_/-— mixeri

i2s2

* _ ' delay1 \& i2s1

' sgtl5000 1 |

Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch

Step #3: In Arduino, open the Part 2-6 example
File > Examples > Audio > Tutorial > Part_2_06_Feedback_Delay and paste the code from
the design tool into the commented section copy the Design Tool code here

Step #4: Verify the sketch and Upload it to Teensy.

When you run the example, you'll clearly hear a 44 S5YLLOYYY_L.vVoLume(v.2d);

repeating echo. The amount of feedback at 43 | sgt15000_1.inputSelect (AUDIO_INPUT MIC);
channel 3 on mixer1 controls how much weaker 45 | ¥4 L wctninitas:

the signal becomes each time it echoes, which in = RS

46 mixerl.gain(3, 0.7);
turn affects the number of echoes heard. 47 delayl.delay(0, 400);

4R dalaviT1AAAY -

Step #5 (optional): Experiment with different feedback gain.

Uncomment two blocks of code near the end of loop(). The first part allows the A3 knob to adjust the
feedback level. If you turn the knob all the up (clockwise), the feedback will be very close to 1.0.
Each time the sound circulates back through the loop, it is reduced only slightly, so it keep echoing for
a very long time.

Feedback signals are risky, if the total signal gain around the loop is ever more than 1.0. If the signal
becomes stronger each time it travels around the loop, it will grow without bound, until clipping. This
is called an unstable feedback loop.

To experiment with an unstable loop, hold the left button to double the feedback. If the knob it turned
up past half, the result is an unstable loop.

In natural echo, the sound decreases but also changes as it echoes. You can create a similar effect by
adding a filter object in the feedback path. Each pass around the loop will decrease the signal and also
decrease its high frequencies even more, to achieve a very natural echo effect. Combinations of
looped delay (a loop within the loop) can create rich reverb effects.
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Part 2-7: Filters

Filters allow a portion of the audio spectrum to pass, while reducing the rest. The simplest filter to use
in the Teensy Audio library is the state variable filter, labeled simply filter in the “filter” section. In
this part, you will listen to filtered music, to hear the effect each type of filtering.

Step #1: Design an audio system

playSdWavl = — —

filterd mixer
.—-l'""__ -\

* oz =38 | m
filter2 — mixerz2 sgl5000_1

i2s1

These mixers as a signal routing switch. One channel will be set to 1.0 gain, to pass the signal straight
through so we can hear the effect of the filter. The other mixer channels will set to zero to block those
signals. The mixers won't actually be doing any “mixing”, just routing one of the filter's outputs.

Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch

Step #3: In Arduino, open the Part 2-6 example
File > Examples > Audio > Tutorial > Part_2_07_Filters and paste the code from the design
tool into the commented section copy the Design Tool code here

Step #4: Verify the sketch and Upload it to Teensy.
Step #5: Listen to each filter type. Vary the filter frequency to hear how the filter changes sound.

The example program uses the 3 buttons to reconfigure the mixers, and the A3 pot to allow you to vary
the filter frequency as the music plays. The serial monitor window will show the actual frequency
setting as you turn the knob. On the low-pass and high-pass signals, the music will seem to get quieter
as you filter away more of its spectrum.

You may have noticed the filter objects have 2 inputs. The second input allows another audio signal to
vary the filter frequency automatically. Details and functions to tune parameters can be found in the
design tool documentation. Strange effects can be achieved by using an oscillator to “sweep” the filter
frequency rapidly.
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Part 2-8: Oscillators and Envelope

Synthesis is the process of creating sounds. In this part, you'll listen to some of the fundamental
syntheis building blocks.

Step #1: Design an audio system

waveform1 (

sine_fm1 ——..__. : / mixer2
i mixer1 -
L - \ 281

' ; envelopel i
sinel -

. sgti5000 1
pink1 '

In this system, waveform1 is the “control waveform”. It is (usually) a relatively low frequency which
controls another signal. Like in the previous example, these mixers are used as switches to allow us to
hear one of the 4 synthesized sounds, and to hear it directly or modified by the envelopel object.
Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch
Step #3: In Arduino, open the Part 2-8 example

File > Examples > Audio > Tutorial > Part_2_08_Oscillators and paste the code from

the design tool into the commented section copy the Design Tool code here

Step #4: Verify the sketch and Upload it to Teensy. Open the Serial Monitor window.

When this sketch runs, the buttons and knobs have these functions:

Button 0 (left): Cycles through the 5 control waveform types
Sawtooth
Sine
Square
Triangle
Pulse
* Button 1 (middle): Cycles through the 4 mixer1 signals
Control Waveform
Frequency Modulated Sine
Pure Sine
White Noise
* Button 2 (right): Activate the envelope
Press = Note Begin
Release = Note End
(after 4 seconds) = Revert to steady tone from mixer1
* Knob A2 (left): Varies control waveform frequency
* Knob A3 (right) Varies sine_fm1 & sinel frequency
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Step #5: Listen to the five control waveform types

If you've already fiddled with the settings, press the middle button until mixer1 is passing the control
oscillator. Then turn knob A2 clockwise, until the control oscillator is a recognizable tone.

Press the left button and listen to each control waveform. The serial monitor will tell you which one is
playing. Each has a distinctive sound.

Step #6: Listen to the modulated waveform with each control type

Turn the A2 knob fully counterclockwise. This will configure the control oscillator to a very low
frequency, far below human hearing. If sawtooth, square or pulse are selected, you may hear
occasional clicking, but the tone of the waveform itself is inaudible.

Press the middle button to configure mixer1 to pass the modulated sine wave. Adjust A3 for a
comfortable tone range.

Listen to the modulated sine with each control waveform (left button). You should be able to hear the
effect of the control waveform shape. Sawtooth causes a gradual rise in tone, the sudden drop back
down. Sine varies the tone back and forth. Square will alternate between 2 tones. Triangle should be
similar to sine, but the tone changes less smoothly. Pulse should be similar to square, except you will
hear one tone nearly all the time and the other only briefly.

Step #7: Experiment with faster control waveforms

While listening to the modulated waveform, increase the control waveform (knob A2). You should
here funny sounds. With sawtooth or triangle control, you should hear strange tones, perhaps
“metallic” sounding, as the control frequency rises much higher.

Step #8: Listen to envelope effect

Adjust the settings for a distinctive sound, and then repeatedly tap the right button to activate the
envelope. Tap it to a simple rhythm.

[= N ‘ i W [45] =

Envelope tries to transform a tone into the intensity profile of |@ % o @ T

a musical note. It rapidly changes the signal level in several = 2 g LN &

h z ¥ = G
phases o

Consider a flute. The attack phase is similar to initially
blowmg'mto the tgbe, causing pressure to build before any S~ roteon Foteoff — time—
substantial sound is hear. The decay phase emulates the

equalizing of pressure between the instrument and musician. The sustain phase is the steady sound
heard as the musician continues blowing in the tube. The final release phase emulates the gradual
decrease in pressure & sound after the musician stops applying air pressure.

These oscillators and envelopes are some of the basic building blocks for synthesis.
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Section 3: Audio Analysis

We played, created and processed sound in the prior sections, which required only simple control from
Arduino sketches to start playing or configure settings. In this section, we'll explore more
sophisticated ways for Arduino code to interact with the audio system. We'll also look at the limitation
of processing audio on a single chip microcontroller.

Part 3-1: Peak Detection

For some projects, like sound reactive costumes and DJ stage lights, your Arduino sketch needs
information about the sound, rather than just allowing the audio system to process it. The analysis
objects fill this role.

Let's start with peak, the simplest [ playSdWav1

analysis object.

BN

Step #1: Design an audio system

The audio playSdWavl1 is sent to
both the audio shield and the peak1 [ sgtis000_1 |
& peak2 objects. A subtle issue is
the need for the i2s1 object. All
audio systems require at least one physical input or output, due to a technical requirement of the
Teensy Audio Library.

Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch
Step #3: In Arduino, open the Part 3-1 example
File > Examples > Audio > Tutorial > Part_3_01_Peak_Detection and paste the code from
the design tool into the commented section copy the Design Tool code here

Step #4: Verify the sketch and Upload it to Teensy.

When you run this code, you should see this display in the Arduino Serial Monitor.

Output  Serial Monitor ¥ O

| BothNL& CR ~

L oty 9.99, ©.99
L oty 9.99, 0.85
L oty 0.99, 0.80
cocasas| |z 0.26, 0.20

cecssas| | = 0.24, 0.14

B ] 0.69, ©.56
B 0.70, 0.45
B 0.60, .38

cooa| | mnmm 9.16, .14

<z<| |5 9.10, .08
CoddddddddddddCddsdaddadad | | mann 0.88, ©.89
CdcdoddddddddCdddCdddddddadad | | mann 9.99, 0.94
e i S ©.99, 6.99
e e e I - 9.88, 0.81
coCdCdasggaggs<<s | | >0 0.62, 0.54

Ln 16, Col 25 Teensy 4.0 onusb1/1-1/1-1.3 (22 B
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The peak objects give numbers between 0 to 1.0, representing the largest amplitude peak of the audio
signal during the time elapsed since the previous reading.

To see the ASCII graphic as it might appear in LEDs on a stereo display, move another window on top
of the Arduino Serial Monitor, or shrink the window size, to block all but the last line.

Output  Serial Monitor ¥ O =
| Both NL& CR =

o o A e o o o o e || e e e e e e e e e e e e e e e e 0.94, 0.64

Ln16,Col25 Teensy 4.0 onusb1/1-1/1-1.3 (22 B

Looking at the code, you can see the peak objects have functions very similar to other Arduino
libraries. The available() function tells you when the you can read more data, and the read() functions
give you the data. These read() give floating point numbers, rather than data bytes.

76 it (msecs > 40) {

77 if (peakl.available() && peak2.available()) {
78 msecs = 0;

79 float leftNumber = peakl.read();

80 float rightNumber = peak2.read();

a1 int Taf+Dasl — TaAaft+hAhimbhaAar % 20 Q.

These familiar-looking functions do have subtle but important differences from Arduino's normal
usage. With incoming Serial data, available() and read() access a queue, where available() tells you
how many items are currently in the queue, and read() removes 1 item from the queue for you. They
are designed to prevent data loss. You want to read the oldest data first, even it if actually arrived
some time ago.

Audio analysis objects are designed to provide only recent information. The available() returns only
true or false. When new information is available, only the most recent data can be read. Audio
analysis is designed to lose old information. Some analysis, like peak, gives you the cumulative effect
since your last read(). Information about smaller peaks is automatically lost as larger peaks occur.
Other types of analysis give you information from a recent window in time, where results from
previous windows are automatically discarded. Details are in each object's documentation in the
design tool.

This example has code to lower the printing speed. It uses an elapseMillis variable, which is a
convenient Teensyduino feature. elapseMillis are integers which automatically increment 1000 times
per second.

62

63

64 elapsedMillis msecs;

65

66 wvoid loop() {

RT AiF InlauCAdllawT 4 eDlavinAall == Falend r

The example only prints if msecs has incremented past 40. Try reducing this number. If you use 0, it
will print every time new peak analysis is available. Though very fast, this speed is 1 update for every
128 audio samples, or about 344 Hz.
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Part 3-2: Fourier Transform

Fourier transform gives you detailed analysis of the audio spectrum. It turns data in time to data in
frequency, which is really useful for building an art installation or costume which reacts uniquely to
sounds in different frequency ranges.

The acronym FFT means Fast Fourier Transform, which refers to a mathematical optimization. FFTs
have two types of output. Complex output gives you 2 numbers per frequency, and is generally needed
if you will turn the frequency data back to an audio signal. The Teensy Audio Library provides the
simpler Real output, where you get a single number per frequency. The numbers tell you the amount
of signal found at each frequency, without any information about its phase shift.

To begin exploring Fourier transform, draw this simple system. Even with the FFT optimization, a
1024 point analysis (which provides detailed results) will tax Teensy's computational power, so only a

single fft1024 object is used. The stereo WAV file is mixed to mono for the sake of analysis.

Step #1: Design an audio system

[ playSdWav1

mixer! )

#1024 _1 ]

[ waveform1

[ sgtl5000 1 ]

Step #2: When the audio system is designed Export and copy the code to paste in the Arduino sketch

Step #3: In Arduino, open the Part 3-2 example
File > Examples > Audio > Tutorial > Part_3_02_XXX and paste the code from the design
tool into the commented section copy the Design Tool code here

Step #4: Verify the sketch and Upload it to Teensy. When run the code, this should appear in the
Arduino Serial Monitor.

I Send
FFT: 0.008 0,017 0,010 0,009 0,615 0,014 0,022 0,005 0,806 - 0,052 0,050 0,008 0,021 0,025 0.G13 0,012 0,004 0,013 0,008 0,005 0,610 0,008 0.007 0,804 - 0,010 0.013 0,005 =
FFT: 0.006 0.015 0.015 0.008 0.018 0.035 0.018 0.004 0.008 0.020 0,077 0.076 0.017 0,020 0.025 0.005 0.007 - 0.004 - 0.005 0.012 0.010 - - - 0.007 0.007

FFT: - 0.012 0.0l7 0.012 0.022 0.044 0.026 - 0.009 0.012 0.071 0.065 0.016 0.017 0.016 - 0.007 - 0,008 - 0.005 0.008 - - - 0.009 0.011 0.008

FFT: 0.005 0.010 0.011 0.012 0.013 0.011 0.019 - 0.013 0.058 0.099 0.058 0,007 0.067 - 0.004 0.004 - 0.005 - - 0,008 0.011 0.006 - 0.004 0,004

FFT: 0.010 0.006 0.006 0.023 0,036 0.016 0.006 0.015 0.014 0,051 0.057 0.017 0,006 0.0098 0.005 - - 0,005 0.004 - - 0.004 0.006 - - - 0.004

FFT: - 0.008 0.010 - 0,011 0.035 0.032 0.009 0.018 0.042 0.018 0.025 0.005 0,009 0.009 - - 0,005 0.011 0.005 - - - - 0.004 0.007 -

FFT: - 0.005 0.009 0.012 0.021 0.034 0.023 0.018 0.035 0.028 0.017 0.006 0.004 - 0.008 0.009 0.005 0.0l4 0,007 0.014 0.021 0.013 0.020 0,032 0.021 - - 0.008 0.007
FFT: - - 0.006 - 0.021 0.048 0.036 0.008 0.011 0.024 0.028 0.032 0.035 0.027 0.013 0.010 0.020 0.038 0,044 0.040 0.050 0.030 0.021 0.045 0.0648 0.028 0.010 0.011 0.017 0.019
FFT: - - - - 0.004 0.024 0.011 0.009 0.006 0.020 0.021 0.012 0.013 0.024 0.019 0.006 0.012 0.017 0.021 0,045 0.039 0.008 0.018 0.032 0.027 0.010 0.009 0.019 0.028 0.011
FFT: - 0.008 - - 0.021 0.054 0.047 0.009 0.006 0.013 - - 0.007 0.007 0.010 0.610 - - 0.009 0.039 0.055 0.024 0.010 0.033 0.628 0.008 0.011 0.019 0.014 0.008
FFT: - 0.007 0.008 0.008 0,020 0.049 0,038 0.008 0.010 0.014 0,011 0.022 0,020 0.008 0.009 0.010 0.009 0,010 0.012 0.027 0.009 0.018 0.008 0,012 0.014 0.033
FFT: - 0.004 0.008 0.006 0,005 0.037 0,033 0.005 - 0.010 0,020 0.023 0.013 - 0,015 0.018 - 0,006 0.014 0.013 0.007 0.008 0.043 0.044 O, 017 [} 016 a. 018 0.014 0.005
FFT: - - - 0.006 0.013 0.057 0.054 0.010 - - 0.008 0.005 - - 09.012 0.018 0.009 0.011 0.015 0.013 - 0.016 0.053 0.051 0.0l4 - 09.0l0 0.008
FFT: - - - 0.006 0.050 0.083 0.017 - 0.005 0.012 0,036 0.038 0.0l - 0.009 0.011 0,010 0.005 0.0l2 0.026 0.012 0,018 0.021 - 0,009 - 0.010 0.017 0.011
FFT: - - - - 0.017 0.055 0.047 0.011 0.005 - 0.022 0.032 0.020 0,013 - 0.004 0.004 0.010 0.023 0,023 0.019 - 0.005 0.022 0.021 0.089 - 0.018 0.026 0.013
FFT: - - - - 0.010 0.042 0.040 0.009 - 0.006 0,022 0.051 0.045 0.018 - - 0.005 0,005 0.020 0.027 0.019 0.008 - 0.015 0.008 - - 0.004 0.019 0.013
FFT: - - - - 0.012 0.048 0.046 0.011 - 0.005 0,626 0.037 0.000 6.009 - - 0.004 0,605 0.009 - 0.007 - 0.607 0.012 0.613 0.006 0.085 0.010 0.019 0.613
FFT: - - 0,007 0.035 0,029 - 0,029 0.050 0,026 0.008 - - - - 0,005 0.007 - 0.007 0.006 0.006 0.010 0,005 - 0.010 0.017 0.012
FFT: - - 0.007 0,037 0.039 0.009 - - 0,032 0,051 0.024 - - - - - 0.006 0.004 0.008 0.005 - 0.006 0.011 0,006 - 0.006 0.010 0.005
FFT: - - 0.012 0.042 0.037 0.008 - 0.031 0.048 0.015 0.006 - - 0.005 - 0.005 0.011 0.010 0.005 0.005 0.009 0.008 0.004 - 0.006 0.004

FFT: 0.010 0.012 0.016 0.041 0.036 - 0.005 0.009 0,025 0.041 0.019 0.007 - 0.007 0.007 - - 0.005 0.008 0.015 0.013 0.014 0.015 0.009 - - - 0.005
FFT: 0.015 0.021 0.015 0.055 0.058 0.018 0.009 0.020 0,033 0.051 0.027 0.005 - 0.015 0.018 - 0.004 0.004 0.010 0.013 0.008 0.012 0.618 0.008 - - 0.004 0.010
FFT: - - 0.011 0.021 0.006 0.044 0.038 0.008 0.009 0.020 0.030 0.036 0.017 0.009 0.020 0.033 0.016 0.008 0,009 - 0.004 0.007 0.007 0.010 0.610 0.007 0.004 0.009 0.009 0.006
FFT: 0.004 - 0.008 0,020 0.010 0,029 0.024 0.006 0.012 0.028 0,033 0.024 - 0,007 0.023 0.029 0.009 - 0.007 0.005 - 0,013 0.012 0.005 - - 0,006 0.011 0.008 0,008
FFT: - 0.005 - 0.015 0.021 0.043 0.028 0.010 0.015 0.029 0,026 0.021 0,015 0.010 0.023 0.030 0.012 - 0.004 0.006 0.005 0.009 0.009 0.005 0.005 - - 0.006 0.007 0.007
FFT: 9.007 0.009 8.011 0.016 0.010 0.023 0.030 0.015 0.016 0.022 0,007 - 0.009 0,010 0.016 0.026 0.015 0.011 0,010 0.006 8.0l0 0.014 0.005 0.004 0,005 0.005 0.087 0.009 0.087 0.004
FFT: 0.005 0.010 0.028 0.031 0.016 0.032 0.025 0.010 0.009 0.023 0.012 0.005 0.008 0.004 0.006 0.014 0.008 0.007 0,010 0.008 0.010 0.012 0.008 0.005 0.007 - - 0.006 0.008 0.008 ‘ |
& Autoscroll Newline v | 9600 baud -
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The FFT analysis produces a tremendous amount of data. This rapidly scrolling window shows only
the first 30 of the 512 frequency “bins”. However, these 30 are much more important than the
remaining 482. Later we'll look at why that is. For now, let's concentrate on understanding these
numbers.

Each frequency bin represents the amount of signal found at a particular frequency. The bins are 43
Hz apart.

Bin @ = DC or zero Hz component
Bin 1 = 43 Hz

Bin 2 = 86 Hz

Bin 3 = 129 Hz

Bin 3 = 172 Hz

Bin 4 = 215 Hz

Bin 5 = 258 Hz

Bin 6 = 301 Hz

Bin 7 = 344 Hz3

etc....

The numbers are all typically small. You may recall from Part 2-2 Mixers that signals range from -1.0
to 1.0. The FFT considers only the total amount, so you get only positive numbers. If a signal total is
1.0, meaning it's actually oscillating between -1.0 to 1.0, the FFT will report it as 1.0, likely spread
across many bins if it's composed of many frequencies.

For example, if a signal with total amplitude of 0.6 which is a mixture of 25% 120 Hz and 75% 1 kHz,
bins clustered around 3 (129 Hz) and around 23 (989 Hz) will indicate the amount of each part. Bin 3
and nearby bins will sum to 0.15, and pin 23 and nearby bins will sum to 0.45. The sum of all bins
always equals the total amount of the signal. There are some finer details to consider, but first let's do
some listening tests to see the data corresponding to real sounds.

Step #5: Guitar listening test

If you press the 3 buttons, you'll hear each activates one of the 3 signal sources you drew in the design
tool. When you listen to the guitar sample from the middle button, you should see this:

Send
FFT: - - - 0.004 0,012 0.111 0.148 0,651 0,005 - - - - - - 0,005 -
FFT: ~ 0.006 0.021 0.043 0.044 0,022 0,010 0,092 0,120 0,038 0,008 0,009 0.007 0.006 0.005 0,008 0.007 0.004 - - 0.004 - - -
FFT: - - 0.006 0.024 0.041 0,028 0,024 0.054 0.089 0.036 0,007 -
FFT: - - - 0.012 0.029 0,041 0.062 0.035 0.057 0.071 0,018 0.004 0. 013 [} 016 a. 016 a. 015 0. 011 0. 009 0. OOB 0. OGB a. OGG a. 004 0.009 0. 009 a. 011 a. 011 a. 009
FFT: - - - 0.008 0.011 0,024 0.132 0.126 0.042 0.054 0,007 0.004 0,018 0,036 0.018 - - 0.004 0.004 0,008 0.008 0.014 0.028 0.013
FFT: - - - - - 0,029 0.130 0.123 0.026 0.058 0,016 0.016 0,035 0,017 - - 0.0089 0.009 0.011 0,025 8,014
FFT: - - - - 0,805 0,022 6,128 0.121 0.019 0,053 0.618 - 0,017 8,033 0.017 - - - - 0.009 0,009 0.011 0,023 08,013
FFT: - - - S 0.025 0.131 0.122 0,617 0,853 0.011 - 0.017 0,033 0,016 - - - - 0,007 0.008 0.018 0,021 8,011
FFT: 0.028 0,131 0.124 0.029 0.060 0,616 - 0.015 0,031 0.016 - 0,008 0.007 0.008 0,018 0,010
FFT: 0,005 0,024 0,127 0.121 0.033 0.055 0.013 0.015 0,030 0.015 - 0.007 0.007 0.007 0.016 0.009
FFT: 0.004 0,026 0,127 0.125 0.042 0.048 0.012 0.015 0,029 0.015 - 0.006 0.006 0.006 0.013 0.008
FFT: 0.025 0,124 8.121 0.047 0.046 0,013 0.014 0,028 0,013 - 0,085 0.005 0.005 0,011 8,007
FFT: 0.025 6,120 0.128 0.056 0.042 0,018 0.015 0,028 0.014 - 0,005 0,005 - 0.009 0,006
FFT: 0.019 8,055 8.070 0.037 0.015 0,010 0,005 0,011 0,013 0.007 0.005 - - -
FFT: 0.086 0.006 0,010 8,611 - - - - - -
FFT: 0.088 0.012 0.016 8.014 0.805 - - - - - ~ 0.005 0.005
FFT: 0.007 0.005 0.006 0.007 - - - - - - - -
FFT: 0.006 0.010 0.013 0.011
FFT: 0.087 0.005 0.009 0,011 0,005
FFT: 0.088 0.010 0.012 0,012 0,004
FFT: 0.088 0.009 0,008 ©.008
FFT: 0.010 0.011 0.009 ©.0608
FFT: 0.010 0.008 0.006 0.007
FFT: 0.010 0.009 0.008 0.011 0.004
FFT: 0.010 0.010 0,006 0,008
FFT: 0.010 0.009 0.008 0,012 0,005
FFT: 0.010 0.008 0,007 0,010
FFT: 0.010 0.009 0.006 .009
& Autoscroll Newline v | 9600 baud o

After the sound stops, it's easy to scroll up and see the notes. In this screenshot, you can see the
moment the string is plucked, which results in a few lines with rapidly changing numbers in many
frequency bins. Then the guitar string vibrates with at least 4 frequency ranges (visible in this data).
Soon the higher frequency components fade, as the guitar string vibration settles towards the
wavelength matching the string length between the player's finger and the bottom of the instrument.
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Step #6: Experiment with thresholds for data visualization

Visually detecting patterns in FFT data of composed music is much harder than a single instrument.
The many separate sounds often overlap in frequency bins. Human hearing and the brain's ability to
discern complex combinations of sounds is pretty amazing.

To improve things a bit, find the printNumber() function near the end of the example.

194 void printNumber(float n} {

195

196 if (n >= 0.004) {

197 Serial.print(n, 3);
198 Serial.print(" ");

199 } else {

200 Serial.print(" R 12
201 1

Editing the threshold. Increase it from 0.004 to 0.024. This will print less detail, allowing you to
more easily see the numbers for only the stronger sounds.

The first song that automatically plays is “Where You Are Now” featuring WolfSky singing. She has a
strong voice, which usually shows up as 1 or 2 columns of numbers scrolling by, as in this screenshot.

Send
FFT: - - - - 0,024 - 0.026 0.059 0.040 0.031 - - - - 0.043 0.043
FFT: - - - - - - - 0.055 0.045 0.028 - - - - 0.040 0.043
FFT: - - - - - - - 0.057 0.053 0.027 - - - - 0,041 0.032
FFT: - - - - - - - 0.057 0.052 0.026 - - - - 0.024 0.033 - - - - - - - - -
FFT: - - - - - - 0.058 0.048 0.025 - - - - 0.029 0,033 - - 0,027 - - - - 0,028 0,027
FFT: - - - - - - 0.053 0.045 - - - 0,025 - 0.032 0.035 - - - - - - - - -
FFT: - - - - - 0,026 0.042 0.070 0.045 - - - - - 0.029 - - -
FFT: - - - 0.037 0.073 0.050 - - - - - 0.028 0.034 - - 0,027
FFT: 0.036 0.076 0.062 - - - - - - 0.031 - - 0.032
FFT: 0.062 0.067 - - - - - 0.030 - - 0.027
FFT: 0.076 0.067 - - - - - 0.029 - - - - - -
FFT: 0,034 0.080 0.064 - - - - - - 0,031 - - - - - - 0,025
FFT: 0.062 0.056 0.026 0.034 - - - - - - 0.026
FFT: 0.066 0.050 0.029 0.034 - - - - - - -
FFT: 0.059 0.043 0.033 0.035
FFT: 0.061 0.039 0.038 0.035
FFT: 0.058 0.041 0.035 0.033
FFT: 0,025 0.066 0.046 - - - 0.038 0,033 - - - - - - -
FFT: - 0.054 0,041 - - - 0.034 0.039 0.048 - - - - - 0.029 0,031
FFT: - - - - - - 0.043 0.079 0.051 - - - 0,033 0.032 0.027 - - - - - - 0.024
FFT: - - - 0,026 - - - 0.052 0.060 - - - 0.027 0.029 0.034 - - - - - - 0.026
FFT: - - - 0.028 - - 0,036 0.074 0.057 - - - - 0.034 0.047 - - - - - - -
FFT: - - - - - - 0.025 0.067 0.051 - 0.028 0.047 - - - - - - -
FFT: - - - - - - - 0.062 0.074 0,039 0.029 0.046 - - - - - - 0,027
FFT: - - - - - - 0.040 0.080 0.068 0.03: 0.026 0.043 - - - - - - 0.030
FFT: - - - - - - - 0.056 0.047 - 0.024 0.039 - - -
FFT: - - - 0,031 - - 0.033 0.060 0.048 - -
FFT: - - - 0.036 - - 0.059 0.080 0.041
® Autoscroll Newline + | 9600 baud ~

Unlike the acoustic guitar piece from the middle button, the guitars and other instruments in this music
have many complex effects applied. Those effects which produce rich and complex sounds tend to
scatter the instrument's numbers across many frequency bins. Because the bins add up to the signal's
total, the numbers in most bins are lower, mostly below this higher 0.024 threshold.

If you have extra time, perhaps try adjusting the threshold to see if other types of sounds become
noticeable in the scrolling data. The printNumber() function also has alternate ASCII art code you can
try, and perhaps even extend or redesign with other patterns to better see the relative signal strength in
each bin?

Scrolling numbers probably won't impress many people, but perhaps instead of printing to the serial

monitor, you could turn LED on/off, animate RGB LEDs to different colors, or control solenoids and
motors to visualize the music?
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Step #7 (optional): Understand FFT mathematical limitations (or skip to Part 3-3)

The right button plays pure sine waves. Each time to press it, you'll hear a higher pitch, until it cycles
through all 12 musical notes. The exact 12 frequencies it plays are from this array.

If you previously edited the printNumber() threshold, restore it to 0.004.

94 int noteNumber = B;
95 const float noteFrequencyl[l1l2]
96 220.00,

a7 233.0e8,

a8 246 .94,

99 261.63,

100 277.18,

101 293.66,

102 311.13,

103 329.63,

104 349 .23,

105 369.99,

106 392.00,

107 415.30

108 ¥:

Press and hold the right button. When Teensy plays 220 Hz (musical note A3), you will see this.

® Autoscroll
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Newline + | 9600 baud ~

This example shows a limitation of the Fourier transform. For signal frequencies which don't align

perfectly on the FFT bin frequencies, you can never have ideal performance.

By default, the fft1024 object uses a Hanning window, which causes frequencies not exactly on a FFT
bin to cluster in the close-by bins, but it also smears the data across several nearby bins. Ideally, you'd
like your 220 Hz frequency to mostly appear in the 215 Hz bin, with some perhaps in the 258 Hz bin.
The Hanning window gets you close, with 0.496 in the 215 Hz bin, and 0.290 in the 258 Hz bin. But
0.211 ends up in the 172 Hz bin, and small amounts go to the 129 and 301 Hz bins, which isn't so
desirable. They still add up to 1.0, the original signal size, but they're smeared across 5 bins.

You can disable the Hanning window by editing this code. Just uncomment the line which sets the
window to NULL. Your signal will be processed by the FFT without any window processing.

78 mixerl.gain(3, ©.0);
79

80

81

82 L

83 delay(1000);

21 Nl auSAlWawl nlaul"CSNTFSTT WAW™ Y -

Page 27 of 31



When you press the button for 220 Hz sine wave tone, you should see this with the window disabled.

Send
FFT 0. 0l6 U.ULB U.025 U.042 U.U8/ U.9/4 U 124 U.UBL U.0U42 U.USZ U.UZ/ U U3 U020 U.ULE U.0l6 U.ULS U.ULI3 U.0IZ2 0,012 U.ULl U.UIU U.0IU U.00Y U.U0Y U 0UB U. 008 U008 U.U0/ 000/ U.tuf A
FFT: - 0,008 0.019 0.037 0.083 0.971 0,126 0.064 0.044 0.034 0.028 0,024 0.021 0.019 0.017 0.016 0.015 0,014 0.013 0,012 0.011 0.Cl1 ©.010 0.010 0,009 0,009 0.008 0.008 0.008 0.008

10.014 0,023 0.039 0.085 0,973 0.125 0.062 0.043 0.033 0,027 0,023 0.020 0,018 0.016 0.015 0.014 0.013 0,012 0.011 @.G11 0.010 .010 0.009 0,009 0.008 0.008 0.008 0.007 0,007

0,01
FFT: 0,024 0.026 0.032 0.047 0,091 0,978 0,120 0.058 0.039 0,030 0.024 0,021 0,018 0.016 0.015 0,013 0.012 0,011 0,010 0.010 0.009 0,009 ©.008 0.008 0,008 0,007 0,007 0,007 0.006 0,006
FFT: 0,033 0.035 0.041 0.055 0.099 0,985 0,114 0.053 0.034 0.025 0.020 0.017 0,014 0.013 0.011 0.010 0.009 0.008 0,008 0.007 0.007 0,006 0.006 0.006 0,005 0.005 0.005 0.005 0.005 0.004
FFT: 0,040 0.041 0.047 0.061 0.104 0,990 0,109 0.048 0.030 0.021 0.015 0.013 0,010 0.009 0.008 0.007 0.006 0.005 0,005 0.004 0.004
FFT: 0.041 0.042 0.048 0.062 0.106 0,992 0,108 0.047 0.028 0.020 0.015 0.011 0,009 0.008 0.007 0.006 0,005 0,004
FFT: 0.038 0.040 0.046 0.060 0,102 0.989 0,110 0.049 0.031 0.022 0,017 0.014 0,011 0.010 0.008 0.008 0.007 0,006 0.006 O. 005 a. OGS a. 904 a. 004 -
FFT: 0.030 0.032 0.038 0.052 0,096 0.983 0.116 0.055 0.036 0.027 0,022 0.018 0,016 0.014 0.012 0.011 0.010 0.010 0,009 0.008 0.008 0.007 0.007 0.007 O. 006 0. 006 [} OGG a. OGG a. GGS a. 005
FFT: 0,020 0.022 0.029 0.045 0.089 0,976 0,122 0.060 0.041 0,031 0.025 0,022 0,019 0.017 0.015 0,014 0.013 0,012 0,011 0.010 0.010 0,009 ©.009 0.008 0,008 0.007 0.007 0,007 0.007 0,006
FFT: 0,007 0.011 0.020 0.037 0.083 0.972 0,126 0.063 0.044 0.034 0.028 0.024 0,021 0.019 0.017 0.016 0.014 0.013 0,013 0.012 0.011 0,011 ©.010 0.010 0,009 0.009 0.008 0.008 0.008 0.007
FFT: 0,006 0.010 0.020 0.038 0.084 0.972 0,126 0.063 0.044 0.034 0.028 0.024 0,021 0.019 0.017 0.015 0.014 0.013 0,012 0.012 0.011 0.010 ©.010 0.009 0,009 0.009 0.008 0,008 0.008 0.007
FFT: 0.019 0.021 0.028 0.044 0.088 0.976 0,122 0.060 0.041 0.032 0.026 0.022 0,019 0.017 0.016 0.014 0.0613 G.612 0,611 0.011 0.010 0.010 ©.005 0.009 0,008 0.008 0.008 0,007 0.007 0.007
FFT: 0.030 0.031 0.037 0.052 0,096 0.982 0.116 0.055 0.036 0.027 0,022 0.018 0,016 0.014 0.012 0.0l1 0.010 0,010 0.009 0.008 0.008 0.007 0.007 0.007 0.006 0,006 0.006 0.006 0.005 0.005
FFT: 0.038 0.039 0.045 0.059 0,102 0.989 0,111 0.050 0.031 0.022 0,017 0.014 0,012 0.010 0.009 0.008 0.007 0.007 0,006 0.006 0.005 (.005 0.005 0.004 0.004 -
FFT: 0,040 0.042 0.048 0.062 0.105 0,991 0,108 0.047 0.028 0,020 0.015 0,011 0,009 0.008 0.006 0,006 0.005 0,004
FFT: 0,040 0.041 0.047 0.061 0.105 0.991 0,108 0.047 0.029 0.020 0.015 0.012 0,010 0.008 0.007 0.006 0.005 0.005 0,004 0,004
FFT: 0,034 0.035 0.041 0.055 0.099 0.985 0,114 0.053 0.034 0.025 0.020 0.016 0,014 0.012 0.011 0.010 0.009 0.008 0,008 0.007 0.007 0. 006 0. 006 . 006 . 005 . 005 0. 005 0. 005 0. 005 0. 004
FFT: 0,025 0.027 0.033 0.048 0.092 0.979 0,119 0.058 0.03% 0.029 0.024 0.020 0,018 0.016 0.014 0.013 0.012 0.011 ©.010 0.009 0.009 0.008 0.008 0.008 0,007 0.007 0.007 0.006 0.006 0.006 ‘ ‘
® Autoscroll Newline v | 9600 baud -

At first glance, this looks pretty horrible. But if you read the actual numbers, you'll see the 215 Hz bin
has numbers between 0.971 to 0.992. The 258 Hz bin is between 0.108 to 0.126. So almost all of our
220 Hz sine wave did go into the 2 desired bins. However, some of it got scattered across almost all
the other bins. This problem is called Spectral Leakage. The windows are meant to prevent spectral
leakage, containing all the results to only nearby frequency bins.

To understand how a pure 220 Hz sine wave becomes data in all those other frequency bins, consider
this plot of 4096 points of a 220 Hz sine wave, sampled at 44.1 kHz.

T AN AN AN AN N fp\ A f |

0 1024 2048 3072 4096

The green box is 1024 points where the FFT analyzes the spectrum. The FFT reports the spectrum
based on the assumption the waveform is periodic, that it repeats indefinitely.

Here is the same 220 Hz waveform with the first 1024 point section repeated 4 times. Without a
window, the FFT is returning the spectrum of this waveform, which differs from the intended 220 Hz
pure sine wave.

: ]’/\‘.\ /\ f\ ‘./“ \ ."n‘. ﬂ f\ \ /\ Ilfr\l ‘Iﬂ \ ,’{\ /\ *.‘ ﬂl .F \ ‘.’[\I ‘.'f\l ,f\
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The window function is just another waveform which the signal is multiplied by, before the FFT. The
Hanning window is basically just an offset sine wave, which multiplies the original waveform by zero
at the beginning and end of the window, and by 1 in the middle.

VA VEANVAANVZAN

-1E 1 1 1
0 1024 2048 3072 4096

Window functions destroy about half of the original data, where they multiply by zero or very small
numbers. For this reason, the Teensy Audio Library uses 50% overlap in its fft1024 object. Twice as
many 1024 point FFTs are computed, where the second set uses the window function offset by 512
points.

With the pure 220 Hz tone, this graph shows the actual windows inputs to each 1024 point Fourier
transform.

1 Il N - . N
\ N n A
II I‘| ‘Il I‘II ‘Iun I‘|‘|‘
‘ | . I |
Al . [ AN
A [\ | | \
T O R [ \ N |‘I \ ! .‘ ‘.‘
'I | [ ‘ \ /\ . I
[ ( | | | | \ [ | \ ~ | | | [
| | \ | \ / 1 | | i / \ | | \
o I R e A N i I R B AR I A O B R AR NS | N I Y R
\ / | [ \ \ I‘ | | \_" S - | | || | \
S B R Y BV A VL] VA I O AV
| \ | \ I f
II‘ ‘II | 7 " |‘ II‘ ‘I‘n ‘I‘ " |‘I e \ ] \ I
\ | || \ \/ | | |/
' \
\V \| | Y
-1k I L A I e
0 1024 2048 3072 2096
' N N .
i\ A
I [ | n
[ [ w'l | II\ N [ “n ‘I | [\
A AR N aua A
A AL L A A L A
- [ / \ [ I | “\ (. [ [ |
i Vo / L SN R I
orF | | \ L \ Il | [ ‘ Nt | \ | | | \ ,/ - \ [ \ | | \ | il
| \” ~ [ [ \\ [ | \ | |‘ T \ [ ]
| [ [ \ ™ | | A% \ I | |
\ | \/ | | \ / | |
||V W Vol |
(| | || | |
\] Y \ \J/
\ .‘" \ \ \/
-1k | I Y =
0 1024 2048 3072 2096

A new 1024 point FFT is completed every 512 samples, because they are performed at twice the rate
on 50% overlapping data after windows are applied.

Because of the 50% overlap, fft1024_1.available() will return true 86 times per second. Each new
update of fft1024 data represents the prior 1024 samples (approximately 23.2 ms) with a window
applied, so it was most sensitive to the sound in the center of those 23.2 ms.

Many different window shapes are available in the library, which trade off spectral leakage versus
smearing of the frequency bins. There is no magic solution if your signals have frequencies not
perfectly aligned onto the FFT bins. But despite these limitations, the FET works great for sound
reactive projects.
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Part 3-3: Add a TFT Display

In this last part, you'll connect a TFT display for visualization of the peak detect analysis.
Step #1: Add the TFT display and connect 5 signals
Disconnect your Teensy from the USB cable before changing breadboard wiring.

Place the TFT display on the last 9 holes of the breadboard, locations 9-G to 1-G.

"
N
L
b
| W
»
|
N
N
)

[
W
|
]
»

Your breadboard already has the 3 VCC and 1 GND connections installed. Five colored wires are
needed to complete the data path.

Signal Color Teensy Bread Teensy Bread Display Bread
3.2 board 4.0 board Pin board
VvCC - 3.3V 3.3V 1
GND - GND GND 2
CS Purple 21 58-A 22 59-A 3 7-)
RESET - 3.3V 3.3V 4
D/C Green 20 57-A 9 53-) 5 5-)
MOSI Brown 7 55-] 11 51-) 6 4-)
SCK Orange 14 51-A 13 50-A 7 3-)
LED - 3.3V 3.3V 8
MISO Gray 12 50-) 12 50- 9 1-)
Teensy 3.2 Wiring Teensy 4.0 Wiring
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Step #2: Design an audio system. This is the same system from Part 3-1.

[ playSdWav1 .

i2s1

[ sgti5000_1 ]

Step #3: When the audio system is designed Export and copy the code to paste in the Arduino sketch
Step #4: In Arduino, open the Part 3-3 example
File > Examples > Audio > Tutorial > Part_3_03_TFT_Display and paste the code from the
design tool into the commented section copy the Design Tool code here

Step #5: Reconnect the USB cable, Verify the sketch and Upload it to Teensy.

When Teensy begins running this sketch, you should see the display show a simple visualization of the
peek level meter.

oolo ©
(J U —— W
3, e ————

j33-aE BN . EEEEEEEEEEEE I

Hopefully this rapidly updated TFT example may inspire you to continue exploring with the Teensy
Audio library.
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